Minecraft 1.16 support

With it's release approaching, we have started the rollout of support for Minecraft 1.16 (The Nether Update).

We currently have 1.16 support enabled on our Europe and Asia regions. North America will follow in the next few days.

We will keep supporting 1.14 for a while after the public release of 1.16. However, we will be dropping support for 1.14.3 shortly after 1.16 releases: upgrade to at least 1.14.6 to keep playing! 

With the 1.16 server update, we are also enabling the skin filter for ALL supported versions: learn more HERE.